I tried to upgrade my silverlight plugin from version 3 (3.0.50106.0) to version 4 (4.0.50917.0). I downloaded the DMG, followed the wizard all the way through, restarted Firefox as requested and saw that I was still at version 3… Strangely, Safari did load and use version 4, so the install was successful. So I searched my entire system fore some remains of Silverlight 3, without success.

The only place I could find the old version mentioned, was in the pluginreg.dat file in my firefox profile. I just erased this file, and it all magically worked!

Leave a Reply

Anti-Spam Quiz: